
 BiblioFile    Version 1.2 

BiblioFile is a reference library management tool.    It is designed to help you to keep track of 
journal references in one or more libraries.    Each entry is assigned a unique numeric 
identifier or index that can be attached to the original article which is then manually filed 
according to the assigned identifier.    In this manner, library entries can easily be cross-
referenced to the original article.

Each library entry has several fields.    In general, no formatting restrictions are enforced, 
though it is recommended that the suggested formats be adopted.

The fields are:

Title
Authors
Source
Volume
Date
Starting page
Ending page
Keywords

Help on any given field may be obtained by pressing F1 while that field is active (i.e., while 
the caret is in that field) or by positioning the mouse cursor over the desired field and 
clicking the right button.    Help on commands may be obtained by selecting the menu option
of interest, moving the highlight bar over the desired command (using the cursor keys) and 
pressing F1.



Procedures

Copying and Pasting

Copying references
Pasting references

Editing

Editing and adding keyword and source entries
Editing and adding references

Input

Creating new bibliographic libraries
Importing keywords and sources
Importing references
Opening existing bibliographic libraries

Output

Exporting keywords and sources
Exporting references
Printing references
Selecting output formats

Searching

Locating reference by index
Searching for references

Tagging

Clearing reference tags
Tagging individual references
Tagging multiple references



Keyboard Shortcuts

The following keystrokes may be used to quickly accomplish some frequently performed 
tasks:

F1 Elicits help on the currently active item (field, control, or menu item).
F2 Activates the Go to option.
F3 Activates the Search option.
F4 Activates the Import option.
F5 Activates the Export option.
F6 Clears all tags.
F7 Forces validation of the current field.



Commands

 

Open 

New 

Close 

Cleanup 

Import 

Export 

Printer Setup 

Print 

Clear Tags 

Exit 

 

Add 

Clear 

Copy 

Paste 

Fast Paste

Keyword Table 

Source Table 

Header 



 

Goto 

Search 



Reference Title

The reference title can be of any length up to 240 characters.    The title box will perform text
wrap automatically.



Reference Authors

The list of authors should follow the format:

<last name> <first initial><middle initial>

Author names should be separated with commas.

For example,

Martin DK,Smith DM,Freedman JA



Keywords

Keywords can be up to 40 characters in length.    Upper and lower case are allowed, but 
ignored when performing a keyword lookup.    If only a portion of a keyword is known, type in
its first few letters and type the F7 key.    A window will appear presenting all matches from 
which you may make your selection.



Source

The source of a reference can be up to 40 characters in length.    Standard abbreviations are 
encouraged, but not required.    If only a portion of the source name is known, type in its first
few letters and type the F7 key.    A window will appear presenting all matches from which 
you may make your selection.



Pasting References

Select Paste from the Edit menu to paste a previously copied reference into the current 
reference.    This is useful when adding several new references from the same source or 
perhaps of the same subject matter.    In either case, filling in those fields that will be 
repeated with each entry can save time.

Select Fast Paste from the Edit menu if you wish to paste references without being asked to 
confirm addition of keywords, sources, and references.

BiblioFile version 1.2, unlike its predecessors, uses the clipboard to perform copy and paste 
operations.    In order to paste data, it must have been saved to the clipboard in NLM header 
format.    Usually this is done by the use of the Copy option under the same menu.    If 
multiple references have been saved to the clipboard, you may paste only the first into an 
existing reference.    However, if you are adding new entries, you may paste all references 
stored in the clipboard.    BiblioFile presents a dialog box after it pastes each entry asking you
to confirm that you wish to add that entry.    This sequence repeats until all entries are 
processed or you abort the paste operation.



Copying References

Selecting Copy under the Edit menu will cause a dialog box to appear prompting for which 
entries to copy.    You may copy all references, only tagged references, or a contiguous range
of references.    You may also select one of four predefined formats.    Use the NLM header 
format if you will be pasting these entries into a BiblioFile database.    Click  to copy 
the selected references into the clipboard.



Adding References

References may be added by selected the Add option under the Edit menu.    A blank 
reference form will be presented.    Fill in each field with the desired information.    Click

 to save the entry or 
 to start over.    Note that the reference is not assigned an index number until it is 

saved.



Editing References

The current reference can readily be edited by selecting the field to be modified using either 
the keyboard or mouse.    You may then modify the field using the standard editing features 
provided by Windows.    Notice that once a change is made, the  and 

 controls become active.    Before leaving any modified reference the user will be 
forced to 

 the changes or 
 the reference to its original state.    If you forget to do this, a dialog box will appear 

to confirm the changes.

If a reference library has been opened in read-only mode, references can be viewed but not 
edited.    See a description of the Open command for information on opening a library in this 
mode.



Library Header

The library header can be up to 80 characters in length and may be used to provide a 
description of the contents of the library.    Selecting Header under the Edit menu allows you 
to edit the header contents.



Opening libraries

Bibliographic libraries may be accessed in one of several ways:

1.    Specify a library name following the program name on a command line.    This will invoke
BiblioFile and automatically open that library.    This can be done from Program Manager 
using the Run option under the File menu.    Alternatively, you can use Program Manager to 
create an application icon and fill in the command line parameter using this same format.    
In either case, if the filename is preceded by a hyphen or if the user does not have write 
access to the library, it will be opened in read-only mode.    

2.    Select the Open option of the File menu.    BiblioFile will display a dialog box allowing you 
to select a library to access.    Check the read only box to open the library in read-only mode.

3.    File Manager allows you to associate file extensions with specific applications.    You may 
associate the .bib file extension with the BiblioFile application and then access the library by 
double-clicking on it in File Manager.

4.    BiblioFile supports the Windows drag-and-drop standard.    If you drag a library file icon 
from File Manager to the running BiblioFile application, the library will automatically be 
loaded.

Each bibliographic library actually consists of four files with the same filename but different 
extensions.    The .bib file contains the references.    The .key file contains the keyword table.  
The .src file contains the source table.    The .ttl file contains the text of the reference titles 
and authors.    Never delete one of these files unless you wish to delete the entire library in 
which case you should be sure to delete all four files.



Creating a Library

To create a bibliographic library, select the New option under the File menu.    A dialog box 
will appear allowing you to enter the name for the new library.    The name may be up to nine
alphanumeric characters in length.



Closing a Library

Selecting Close under the File menu will close the current library.    If you have made any 
changes to the current reference, you will be prompted to save them.



Exporting References

References may be exported to a file for inclusion in a document or for merging into another 
bibliographic library.    

To export references select the Export option under the File menu.    This will activate a 
dialog box that permits you to specify the format and filename.    You may export all 
references, only tagged references, or a contiguous range of references.    Alternatively, you 
may export the keyword or source table.



 
Importing References

References may be imported from any text file containing references in NLM header format.   
This is the standard format produced by most literature search services.      You may activate 
this option by selecting Import under the File menu.    A dialog box will appear allowing you 
to select the file for import.    A file type of ".txt" is assumed.    Click the automatic import box
if you do not wish to be prompted before adding each imported reference, keyword, or 
source entry.    Otherwise, you will have an opportunity to review each imported reference 
before accepting (by clicking ) or rejecting (by clicking 

) it.    You will also be asked to review any keyword or source entries that are new.    To
accept an entry click 

 and then 
.    To reject an entry click 
 only.    To cancel the import procedure you may click 
 at any time.

You may also use the import feature to merge keyword and/or source entries exported from 
another library into your current library.    These must have been exported using the keyword
or source table format.    This is particularly useful when setting up a new library where you 
wish to use a keyword or source list from another library.



Setting Up the Printer

Select the Setup option under the File menu to activate this function.    You will be presented 
with a list of all active printers.    Select the printer you wish to use.    Then click  if 
you wish to change the printer settings.    Setup options are specific to the printer driver 
being used.

You may also activate the printer setup function from within the Print option by clicking on
.



Printing References

Select the Print option under the File menu to print your references.    Printing references is 
very similar to exporting them.    You will be presented with a dialog box asking the format to
use.    You may also limit printing to tagged references or any contiguous range of references
by checking the appropriate option.

Clicking  will bring up the setup dialog box.    See printer setup for information on 
how to use this option.



Tagging References

References may be tagged manually by clicking the tag box for the displayed reference or 
during a search when a reference meets the selected search criteria.    Searching, copying, 
exporting and printing can be restricted to tagged references only.

Tags may be removed individually by clicking the tag box, within a group during a search 
operation (when performed with the tagged references only option) or collectively by 
selecting the Clear tags option under the File menu.    Tags are also cleared when a library is 
closed.



Page Numbers

There are fields for the starting and ending page number for a reference.    If the ending 
number is not specified, it is assumed to be the same as the starting number.    Entries must 
be positive integers.    If the second page number is less than the first, BiblioFile will adjust it 
accordingly.    For example, if the starting page is 100, and 12 is entered for the ending page,
112 will be stored for the ending page.



Journal Volume

The reference volume field is used to store the volume number (and issue number if any) of 
the journal.    For example,

120(4)

represents volume 120, issue 4.



Journal Date

This field represents the publication date of the journal containing the reference.    The 
recommended format is

YYYY MMM DD

For example,

1991 JAN 12



Cleaning Up a Library

The Cleanup option under the File menu reclaims unused file space created when keywords 
or sources are deleted.    This is usually only necessary after many such deletions, but no 
harm is done if it is performed more often.



Exiting BiblioFile

The Exit option under the File menu closes the active library, prompting you to save any 
changes to the current reference, and exits the program.    Pressing the escape key in the 
main windows accomplishes the same thing.



Locating a Reference by Index

The Goto option under the Locate menu prompts you to enter a reference index.    That 
reference then becomes the active reference.    This is useful when you have the original 
article and wish to refer to its library entry.



Searching for References

The Search option under the Locate menu activates the search dialog box.    Up to six 
separate search criteria can be specified in a single search.    Each criterion is divided into 
four components arranged in four columns with the headings Not, Item, Value, and And/Or.    

The Not component is simply a box that when checked negates the criterion result.    That is, 
the criterion evaluates to true only when the designated value is not present.    The default 
state for this is not checked.

The Item component is a list box containing which field is to be examined for the specified 
value.    Any field may be searched, but the manner and efficiency varies.    The fastest 
searches are by keyword or source fields because these are stored as compressed two-byte 
values.    Keyword and source matches are by exact match only because of this structure.    
Title, author, volume, and date searches on the other hand are the least efficient.    These 
values are stored as text strings and a valid match occurs when the field contains the 
specified value.    Thus, when one searches the title field for the value "asthma", any title 
containing the word asthma will be a valid match.    Finally, one may specify the page field in
the search criteria.    A match occurs when the specified value falls between the inclusive 
range bounded by the beginning and ending pages.    Page searches are also quite fast 
because they involve only integer comparisons.    The default item to be searched is always 
the keyword field.

The Value component is the value to be searched for.    All searches, regardless of which field
is being searched, are case-insensitive.

The And/Or component controls how the current search criterion is to be combined with the 
following criterion.    The default action is to "and" the results, that is only if both results are 
true is the combined outcome true.    If the "or" option is selected, the combined outcome is 
true if either result is true.

If any tagged entries exist, an additional set of mutually exclusive options is available that 
determines which entries are to be searched.    The Untagged option is the default selection 
and causes only untagged references to be searched.    Any tagged references remain 
tagged after the search.    This is equivalent to "oring" a sequence of searches together.    
Select the Tagged option for only those entries to be searched.    With this option active, any 
tagged entry not meeting the search criteria is untagged.    This is equivalent to "anding" a 
sequence of searches together.    Selecting the Reset tags option causes all reference tags to
be cleared before beginning the search.

Once the search criteria are specified, clicking OK will begin the search.    A window will 
appear showing the progress of the search.    Each entry meeting the match criteria is 
automatically tagged. When completed, the number of matches is displayed.    Clicking OK 
returns to the main window.



Changing the Current Reference

There are a number of methods available to change the currently selected reference.    If the 
index of the desired reference is known, it may be viewed by selecting the GoTo option 
under the Locate menu.    A dialog box then appears prompting you to enter the index for the
reference.

Alternatively, one may select references using any of the four button controls at the bottom 
of the main window.    These function as follows:

Selects the next reference.
Selects the previous reference.
Selects the next tagged reference.
Selects the previous tagged reference.



Erasing the Current Reference

Selecting the Clear option under the Edit menu will erase all fields in the displayed 
reference.    This may be undone by clicking on .



Editing the Keyword and Source Tables

BiblioFile maintains a sorted list of all keyword and source table entries.    This provides for 
very rapid searching on these fields.    Entries in these tables may easily be added or edited 
by activating the corresponding dialog box.    This can be done in one of two ways.    
Whenever an attempt is made to enter an unrecognized keyword or source into a field, the 
appropriate dialog box is activated, allowing one to add the new entry, make an alternate 
selection, or edit an existing entry.    Alternatively, either dialog box may be activated by 
selecting either the Keyword Table or the Source Table option under the Edit menu.

Both the source and the keyword dialog boxes have identical formats.    A list box of all 
current entries is presented in the lower left corner.    You may select an existing entry by 
selecting from this list or you may type the entry into the edit box immediately above the 
list.    In the latter case, the entry that matches what has been typed will dynamically scroll 
into view.

In the upper left hand corner of the dialog box is an edit box labeled New Entry.    To create a 
new entry in the list, select this box, type in the new entry, and click .    The new 
entry will appear in the list.

To modify an existing entry, select the entry by one of the methods discussed above, enter 
the modified entry into the New Entry box, and click .    The old entry will be changed
to the new entry.    All references containing the entry will automatically be updated to reflect
the change.

To delete an existing entry, select the entry from the list box and click .    The entry is
removed from the table.

To undo the last action, click .    To save all changes to the list and return to the 
previous window, click 

.    To cancel all changes, click 

.



Saving Changes

The  button becomes active when any change is made to the displayed reference.    
To permanently save any changes click this button.



Restoring the Displayed Reference

The  button becomes active when any change is made to the displayed reference.    
To restore the reference to its previous state, click this button.



Bibliographic Formats Available

Currently four bibliographic formats are available for printing and exporting:

Standard Bibliographic Format

Martin DK, Smith DM, Freedman J.    Use of a discharge prescription profile to reduce polypharmacy 
and medication errors.  JAMA    1993;134(38):134-38.

NLM Header Format

TI - Use of a discharge prescription profile to reduce
              polypharmacy and medication errors.
AU - Martin DK
AU - Smith DM
AU - Freedman JA
SO - JAMA 1993 Feb 12;134(38):134-38
MH - Computers
MH - Polypharmacy
MH - Medication errors
MH - Quality assurance

Keyword Table
Source Table

These formats export only the respective table in NLM header format.    This is useful for 
later import to another bibliographic library, effectively merging entries from one library into
another.



The File List Box

The file list box appears in the file open dialog box and presents all files in the selected 
directory of a particular type.    For example, selecting the Open option under the File menu 
presents a dialog box whose file list box contains all files of type ".bib" representing 
bibliographic libraries.

A file may be selected from the list box by clicking on it with the mouse.    Double clicking an 
entry is equivalent to selecting it and clicking .



The Directory List Box

The directory list box appears in the open file dialog box and presents a list of all directory 
entries below the currently selected directory as well as the parent directory if any.    Select a
new directory by double clicking on the desired entry.    The file list box will be updated 
automatically.



The Drive List Box

The drive list box appears in the open dialog box and presents a list of all known drive 
letters.    Select a new default drive by double clicking the desired entry with the mouse.    
The file and directory list box are updated automatically.



The Filename Edit Box

The filename edit box shows the currently selected file if one exists.    You may also manually
enter a filename from the keyboard.






